Search found 4 matches

by abelian
Sun Feb 24, 2019 7:16 pm
Forum: Stereo soundcard for the Raspberry Pi
Topic: Audioinjector availability?
Replies: 0
Views: 415

Audioinjector availability?

I see that Amazon UK are not listing these in quantity, just single ones from alternative suppliers at much higher price than normal. Are they still being made or is the Audioinjector obsolete? I want to order fifteen of them for a project.
by abelian
Mon Feb 19, 2018 3:31 am
Forum: Octo Sound Card for the Pi
Topic: Artifacts when capturing at 96k/sec
Replies: 0
Views: 1276

Artifacts when capturing at 96k/sec

Glitches occur as the input signal moves through about +1.3V and -1.3V, as highlighted in the following capture of a 130Hz 5.0 Vpp sine wave: http://abelian.org/vlf/tmp/180218b.gif This is channel 1 on the Octo, at 96k/sec with input gain set at the default 38 in alsamixer. The glitches always occur...
by abelian
Thu Jan 25, 2018 8:54 pm
Forum: Octo Sound Card for the Pi
Topic: I2S sync errors
Replies: 3
Views: 1717

Re: I2S sync errors

Thanks Matt, Yes the root cause was with my application! The I2S sync error messages appear to be a normal result of starting or restarting the ALSA read interface. Hence I get a sync error in dmesg every time the application gets a read error and calls snd_pcm_prepare(). The read errors turned out ...
by abelian
Wed Jan 24, 2018 6:25 pm
Forum: Octo Sound Card for the Pi
Topic: I2S sync errors
Replies: 3
Views: 1717

I2S sync errors

Running capture at 96k frames per second, I get frequent but irregular soundcard read errors, with errno saying 'Broken pipe'. Operation is restored by calling snd_pcm_prepare() again on the device. Happens up to four times per hour, sometimes it will run for a couple of hours between occurances. Ea...