Search found 8 matches

by Dloranger
Fri Mar 09, 2018 8:34 am
Forum: Octo Sound Card for the Pi
Topic: Testing Octo
Replies: 19
Views: 6562

Re: Testing Octo

Just as a couple thoughts if you haven't already figured out a solution, as I have been having some issues as well/ I manually performed the setup as outlined in the forum. All that went fine. run alsamixer, and use F5 to see all the signals, I usually set mine to 60%ish so I have room both ways and...
by Dloranger
Mon Mar 05, 2018 7:13 am
Forum: Octo Sound Card for the Pi
Topic: How to find channel no. related to audio injector octo sound card
Replies: 3
Views: 1073

Re: How to find channel no. related to audio injector octo sound card

some additional information. I turned on device tree debugging (dtdebug=1) and read the logs On a bad boot (not loaded, but registers on i2c) I get the exact same messages (excluding time stamps). My I2C GPIO expanders which are loaded after the octo in the same device tree blob, are just fine howev...
by Dloranger
Sun Mar 04, 2018 6:44 am
Forum: Octo Sound Card for the Pi
Topic: How to find channel no. related to audio injector octo sound card
Replies: 3
Views: 1073

Re: How to find channel no. related to audio injector octo sound card

I am seeing something similar, along with intermittent detection of the card between boots. Note during these tests the hardware is sitting in isolation on my backplane board with the scope attached. Nothing is disturbing the hardware in any way except reboots are done via command line and power cyc...
by Dloranger
Thu Feb 08, 2018 4:15 pm
Forum: Octo Sound Card for the Pi
Topic: what GPIO is the octo really consuming, conflicting information between forum and dtoverlay
Replies: 2
Views: 962

Re: what GPIO is the octo really consuming, conflicting information between forum and dtoverlay

Part of the reason I am digging into this is I am getting erratic behavior from my boards, and I think there might be a gpio conflict, but I just can't tell from the information online. the Octo does not always load up with the overlay, although I can still see it when running i2cdetect tools. other...
by Dloranger
Thu Feb 08, 2018 4:06 pm
Forum: Octo Sound Card for the Pi
Topic: what GPIO is the octo really consuming, conflicting information between forum and dtoverlay
Replies: 2
Views: 962

what GPIO is the octo really consuming, conflicting information between forum and dtoverlay

In looking at the device tree overlay, it would appear that the following GPIO are being used 0, 12, 24,36 gpio = "/fragment@2/__overlay__:mult-gpios:0", "/fragment@2/__overlay__:mult-gpios:12", "/fragment@2/__overlay__:mult-gpios:24", "/fragment@2/__overlay__:mult-gpios:36", "/fragment@2/__overlay_...
by Dloranger
Tue Jan 16, 2018 2:25 pm
Forum: Octo Sound Card for the Pi
Topic: Loading other I2c devices through device tree causes octo to not load
Replies: 2
Views: 718

Loading other I2c devices through device tree causes octo to not load

I am trying to get the octo to load alongside 2 MCP23017 gpio expanders on the i2c addresses 0x20 and 0x21 within the device tree. If I don't have the gpio expanders connected, the octo loads fine at address 0x48 (shows as UU), but if I have the gpio expanders connected, they load fine but the octo ...
by Dloranger
Thu Jan 11, 2018 10:33 am
Forum: Octo Sound Card for the Pi
Topic: Where has github user/content gone?
Replies: 1
Views: 608

Where has github user/content gone?

I went looking for the breakout schematics (RCA specifically) and the entire github user "flatMax" has been deleted. All links from google are now broken.