Ultra Sound Card setup

Moderator: flatmax

Post Reply
hystrix
Posts: 4
Joined: Tue Aug 01, 2017 4:23 am

Ultra Sound Card setup

Post by hystrix » Sun Nov 04, 2018 2:28 am

I have tried for hours to get this card working, but cannot record anything (assuming that I should be able to record using the on-board mics).

I have installed the latest version of Raspbian, and I am using a Pi Zero W.

Here's the output from $ arecord -l

Code: Select all

**** List of CAPTURE Hardware Devices ****
card 0: audioinjectorul [audioinjector-ultra], device 0: bcm2835-i2s-cs4265-dai1 cs4265-dai1-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
alsamixer shows the following under capture devices:
alsamixer.JPG
alsamixer.JPG (40.74 KiB) Viewed 169 times
I am using the following command, which records nothing:

Code: Select all

arecord -D plughw:0,0 -r 192000 -c 2 -f S16_LE -d4 /home/pi/test.wav
Can anyone help me configure this sound card?

Many thanks.

hystrix
Posts: 4
Joined: Tue Aug 01, 2017 4:23 am

Re: Ultra Sound Card setup

Post by hystrix » Sun Nov 04, 2018 10:31 pm

I'm going to answer my own question :-)

It was just a case of setting ADC Mux to "Mic" (a value of zero). Setting it to "1" changes it to "Line In".

"PGA Volume" sets the volume (min value = 0 or -12dB and max value = 48 or 12dB).

A simple bash script with the following will set the mic up for recording:

Code: Select all

amixer cset name='ADC Mux' 0
amixer cset name='PGA Volume' 44
..and record using:

Code: Select all

arecord -r 192000 -f S16_LE -c 2 -d 5 /tmp/test.wav
I get a nice spectrogram from my bat simulator. Not much noise here 8-)

spectrogram.JPG
spectrogram.JPG (65.86 KiB) Viewed 165 times

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests