How to setup and test

Moderator: flatmax

wh7qq
Posts: 24
Joined: Tue Jun 27, 2017 4:07 pm

Re: How to setup and test

Post by wh7qq » Sat Sep 07, 2019 8:05 am

Has anyone tried to get it running with Raspbian Buster? I am beating my head against it right now and so far, have nothing but confusion.

Victorb
Posts: 1
Joined: Tue Oct 01, 2019 4:41 pm

Re: How to setup and test

Post by Victorb » Tue Oct 01, 2019 4:54 pm

I have AudioInjector. Setup is done following your instructions step by step.
Raspberry PI3 B+.

The card is discoverable by system.

Keep having this
aplay: pcm_write:2053: write error: Input/output error

dmesg:
audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 5.222891] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[ 5.460281] wm8731 1-001a: Assuming static MCLK
[ 5.460348] wm8731 1-001a: 1-001a supply AVDD not found, using dummy regulator
[ 5.460501] wm8731 1-001a: Linked as a consumer to regulator.0
[ 5.460518] wm8731 1-001a: 1-001a supply HPVDD not found, using dummy regulator
[ 5.460595] wm8731 1-001a: 1-001a supply DCVDD not found, using dummy regulator
[ 5.460688] wm8731 1-001a: 1-001a supply DBVDD not found, using dummy regulator
[ 5.474617] audioinjector-stereo soc:sound: wm8731-hifi <-> 3f203000.i2s mapping ok
[ 438.915976] bcm2835-i2s 3f203000.i2s: I2S SYNC error!

i2c_arm and i2s interfaces are on

Linux raspberrypi 4.19.75-v7+ #1270 SMP Tue Sep 24 18:45:11 BST 2019 armv7l GNU/Linux

Any suggestions where is the mistake on my side?

Thank you in advance,
Victor

Pijit
Posts: 2
Joined: Thu Oct 24, 2019 5:49 am

Re: How to setup and test

Post by Pijit » Thu Oct 24, 2019 6:07 am

I set up and tested the board. I get the results as pictured. But, I’m not getting any sound in through the line inputs when I connect a device such as an iPad.

VLC media player indicates that the audioinjector is the default audio device. I -can- play a music file from the Pi to speakers connected to the audioinjector line outputs.

Media Player, Media, Open capture device, capture mode is set to video camera (no option for Injector), audio device name defaults to hw:0,0. Error: VLC is unable to open the MRL ‘v4l2://‘.

jon.grady
Posts: 3
Joined: Mon Nov 04, 2019 2:30 pm

Re: How to setup and test

Post by jon.grady » Mon Nov 04, 2019 2:33 pm

I ran the automatic installation and I am able to see the board and the MIC works, but I am unable to hear any output. I have red x's on all the streams in the sound settings but no streams are muted.

Here is what I'm seeing in the dmesg:
[ 4.960021] usbcore: registered new interface driver brcmfmac
[ 4.960725] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 4.960741] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[ 5.150439] random: crng init done
[ 5.150456] random: 7 urandom warning(s) missed due to ratelimiting
[ 5.182898] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 5.182929] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[ 5.187785] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 5.187816] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[ 5.204505] vc4-drm soc:gpu: bound 3f600000.firmwarekms (ops vc4_fkms_ops [vc4])
[ 5.223715] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[ 5.223877] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[ 5.224833] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Oct 23 2017 03:55:53 version 7.45.98.38 (r674442 CY) FWID 01-e58d219f

kbshowle
Posts: 1
Joined: Wed Nov 06, 2019 7:43 am

Re: How to setup and test

Post by kbshowle » Wed Nov 06, 2019 7:50 am

Hi, I've been trying hard to get the audio injector going, but I'm striking out. I've read all the replies in this forum topic and tried everything I found.

I'm on a Pi 4 with Raspbian Buster (full).
I git cloned "https://github.com/Audio-Injector/stereo-and-zero.git" and used dpkg to install "audio.injector.scripts_0.1-1_all.deb".
I ran "audioInjector-setup.sh", which updated me to kernel 4.19.81-v7l+

My config.txt includes these lines:
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=spi=on
#dtparam=audio=on
dtoverlay=audioinjector-wm8731-audio

My "aplay -l" looks like this:

i@raspberrypi:~ $ sudo aplay -l
aplay: device_list:272: no soundcards found...


My dmesg return looks like this (note it's not show any " wm8731-hifi <-> 3f203000.i2s mapping ok"):

pi@raspberrypi:~ $ dmesg | grep -i "wm8731"
[ 3.740252] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 3.982929] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 3.985107] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 4.081284] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 4.105405] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 4.142516] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 4.567431] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 4.568215] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 4.636583] wm8731 1-001a: Assuming static MCLK
[ 4.636614] wm8731 1-001a: 1-001a supply AVDD not found, using dummy regulator
[ 4.636701] wm8731 1-001a: Linked as a consumer to regulator.0
[ 4.636724] wm8731 1-001a: 1-001a supply HPVDD not found, using dummy regulator
[ 4.636822] wm8731 1-001a: 1-001a supply DCVDD not found, using dummy regulator
[ 4.636903] wm8731 1-001a: 1-001a supply DBVDD not found, using dummy regulator
[ 4.647777] wm8731 1-001a: Failed to issue reset: -121
[ 4.648284] wm8731: probe of 1-001a failed with error -121
[ 57.048513] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry

Any ideas?

jon.grady
Posts: 3
Joined: Mon Nov 04, 2019 2:30 pm

Re: How to setup and test

Post by jon.grady » Sun Nov 17, 2019 2:06 pm

I'm having the exact same issue as Victorb.

Any suggestions?

jon.grady
Posts: 3
Joined: Mon Nov 04, 2019 2:30 pm

Re: How to setup and test

Post by jon.grady » Mon Nov 18, 2019 8:51 am

Tried to comment on here a few times but don't seem to get any response. Should I be posting elsewhere?

Here is the output of my dmesg.

[ 5.140731] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 5.140754] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[ 5.150521] brcmfmac: F1 signature read @0x18000000=0x1541a9a6
[ 5.162480] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[ 5.162757] usbcore: registered new interface driver brcmfmac
[ 5.163600] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 5.163617] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[ 5.186294] Console: switching to colour frame buffer device 100x30
[ 5.216313] vc4-drm soc:gpu: fb0: DRM emulated frame buffer device
[ 5.283083] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[ 5.283105] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[ 5.513626] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[ 5.513729] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[ 5.514920] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Oct 23 2017 03:55:53 version 7.45.98.38 (r674442 CY) FWID 01-e58d219f
[ 6.262438] wm8731 1-001a: Assuming static MCLK
[ 6.262472] wm8731 1-001a: 1-001a supply AVDD not found, using dummy regulator
[ 6.262590] wm8731 1-001a: Linked as a consumer to regulator.0
[ 6.262607] wm8731 1-001a: 1-001a supply HPVDD not found, using dummy regulator
[ 6.262672] wm8731 1-001a: 1-001a supply DCVDD not found, using dummy regulator
[ 6.262741] wm8731 1-001a: 1-001a supply DBVDD not found, using dummy regulator
[ 6.269066] audioinjector-stereo soc:sound: wm8731-hifi <-> 3f203000.i2s mapping ok

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests