How to setup and test

Moderator: flatmax

terry1769
Posts: 6
Joined: Tue Oct 24, 2017 10:08 am

Re: How to setup and test

Post by terry1769 » Sun Feb 18, 2018 7:45 am

Including ls below just to show the .wav file exists and in case I'm making a dumb mistake.

pi@raspberrypi:~ $ ls app
Adafruit_CharLCD.py gettime1.py mixertest.py schedset.py test2.py timeset1.py
Adafruit_CharLCD.pyc lookdave.wav mp3play.py schedset.pyc test3.py timeset2.py
audiostuff.py main.py oldmenu_0.5.py setclocks.py test4.py usb1
audiostuff.pyc menu_0.5.py oldmenu.py setclocks.pyc test5.py
calget.py menu.py pico_build startme.py test6.py
calget.pyc menu.pyc rotary_encoder.py startme.pyc test7.py
getslider1.py message.wav rotary_encoder.pyc test1.py tests

pi@raspberrypi:~ $ aplay app/lookdave.wav
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM anyChannelCount
aplay: main:788: audio open error: No such file or directory

flatmax
Posts: 602
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Wed Feb 21, 2018 12:29 pm

Oh - your .asoundrc or /etc/asound.conf file are declaring the plugin anyChannelCount - this plugin is for the octor device. Are you using the octo device or the stereo sound card ?
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

terry1769
Posts: 6
Joined: Tue Oct 24, 2017 10:08 am

Re: How to setup and test

Post by terry1769 » Wed Feb 21, 2018 1:33 pm

Stereo. Guess I'll go back through the setup again.

terry1769
Posts: 6
Joined: Tue Oct 24, 2017 10:08 am

Re: How to setup and test

Post by terry1769 » Thu Feb 22, 2018 2:45 am

Thanks! I deleted .asoundrc and reinstalled. It appears to be working now.

flatmax
Posts: 602
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Sat Feb 24, 2018 1:51 pm

Great news !
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

jon166
Posts: 1
Joined: Wed Feb 28, 2018 6:19 pm

Re: How to setup and test

Post by jon166 » Wed Feb 28, 2018 10:20 pm

Tengo instalado el sistema operativo osmc y no consigo de ninguna manera poder instalar la tarjeta de audio audioinjector.Alguien tiene idea de como hacerlo?

flatmax
Posts: 602
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Sat Mar 24, 2018 12:10 pm

Can you link to the osmc operating system ?

thanks
Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

PGoldie
Posts: 3
Joined: Mon Mar 26, 2018 11:47 am

Output GREAT! No inputs.

Post by PGoldie » Mon Mar 26, 2018 12:00 pm

Very excited about this board, and slugging through the last part of the install. I can play though the output channels, but get no joy from any input options. All testing and ALSC settings as you described. Can it be related to the dmesg message?

Code: Select all

[    6.423522] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    6.423552] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    6.553794] wm8731 1-001a: Assuming static MCLK
[    6.555763] wm8731 1-001a: 1-001a supply AVDD not found, using dummy regulator
[    6.556441] wm8731 1-001a: 1-001a supply HPVDD not found, using dummy regulator
[    6.556703] wm8731 1-001a: 1-001a supply DCVDD not found, using dummy regulator
[    6.556823] wm8731 1-001a: 1-001a supply DBVDD not found, using dummy regulator
[    6.564947] audioinjector-stereo soc:sound: wm8731-hifi <-> 3f203000.i2s mapping ok
I'm prepared to send more data if this is not a clue.

PGoldie
Posts: 3
Joined: Mon Mar 26, 2018 11:47 am

Re: Output GREAT! No inputs.

Post by PGoldie » Wed Mar 28, 2018 12:31 pm

Good news! Apparently the install went fine, but the soundcard input is barely responsive to some low signals. I was using mp3 playing from a cell phone at max output, but it was barely perceptible at max gain. Soon as I switched to a laptop source, it got into usable range. Balancing signals from a source playing on VLC on the RPi combined with inputs from external sources is tricky. Any suggestions on source balancing?

My goal is to use this RPi for internet radio streaming via Icecast. Very glad that I am not stuck on the card configuration stage and can move toward streaming functionality.


PGoldie wrote:
Mon Mar 26, 2018 12:00 pm
Very excited about this board, and slugging through the last part of the install. I can play though the output channels, but get no joy from any input options. All testing and ALSC settings as you described. Can it be related to the dmesg message?

Code: Select all

[    6.423522] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    6.423552] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    6.553794] wm8731 1-001a: Assuming static MCLK
[    6.555763] wm8731 1-001a: 1-001a supply AVDD not found, using dummy regulator
[    6.556441] wm8731 1-001a: 1-001a supply HPVDD not found, using dummy regulator
[    6.556703] wm8731 1-001a: 1-001a supply DCVDD not found, using dummy regulator
[    6.556823] wm8731 1-001a: 1-001a supply DBVDD not found, using dummy regulator
[    6.564947] audioinjector-stereo soc:sound: wm8731-hifi <-> 3f203000.i2s mapping ok
I'm prepared to send more data if this is not a clue.

BillyBadWord
Posts: 1
Joined: Sun Apr 08, 2018 1:48 am

Re: How to setup and test

Post by BillyBadWord » Sun Apr 08, 2018 1:52 am

Hi, I have set both the octo and stereo cards up only to get audio out of one channel. I have used multiple pi's to check if it is my equipment. not sure what to do can anyone help?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest