How to setup and test

Moderator: flatmax

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Tue Feb 07, 2017 10:22 am

Great to hear !

To install sox, this should work :
sudo apt-get install sox

You can hook up your own electret Microphone, sounds like a plan. Let us know how you proceed.

Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

namdoog
Posts: 5
Joined: Tue Jan 31, 2017 9:55 am

Re: How to setup and test

Post by namdoog » Wed Feb 08, 2017 7:27 am

flatmax wrote: You can hook up your own electret Microphone, sounds like a plan. Let us know how you proceed.
Matt
I have recorded a test clip with an external electret mic.

Note that a standard 0.1" header fits in the Cmic1 pads on your board. :)
Attachments
mic_connection.jpg
mic_connection.jpg (156.62 KiB) Viewed 33503 times

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Wed Feb 08, 2017 7:51 am

Nice work ! Glad everything is progressing well.

Mat
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

rod_amaral
Posts: 3
Joined: Wed Apr 05, 2017 12:01 pm

Re: How to setup and test

Post by rod_amaral » Wed Apr 05, 2017 12:31 pm

Hi guys,

I have some problems with the audioinjector installation. I will describe below the order of the installation that i'm doing:

1) Installing the Raspibian Pixel (Fresh Image)
2) apt-get update, upgrade, update-dist, rpi-upgrade and reboot
3) Include dtoverlay = audioinjector -wm8731-audio in the config.txt file
3) I commented the dtparam = audio = on in the config.txt file

However, i can't get any sound.
In Qjackctl it is possible to see audioinector in the options and start the jackd, but also without any sound.

Here are some information:

config.txt

Code: Select all

#dtparam=audio=on
dtoverlay=audioinjector-wm8731-audio
aplay -l result:

Code: Select all

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: audioinjectorpi [audioinjector-pi-soundcard], device 0: AudioInjector audio wm8731-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Audio Test:

Code: Select all

aplay piano2.wav
Playing WAVE 'piano2.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo
aplay: pcm_write:1939: write error: Input/output error
Raspibian log:

Code: Select all

Apr  5 01:51:00 raspberrypi kernel: [    4.460758] audioinjector-audio soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
Apr  5 01:51:00 raspberrypi kernel: [    4.460778] audioinjector-audio soc:sound: snd_soc_register_card failed (-517)
Apr  5 01:51:00 raspberrypi kernel: [    4.463801] wm8731 1-001a: Assuming static MCLK
Apr  5 01:51:00 raspberrypi kernel: [    4.463832] 1-001a supply AVDD not found, using dummy regulator
Apr  5 01:51:00 raspberrypi kernel: [    4.463915] 1-001a supply HPVDD not found, using dummy regulator
Apr  5 01:51:00 raspberrypi kernel: [    4.463969] 1-001a supply DCVDD not found, using dummy regulator
Apr  5 01:51:00 raspberrypi kernel: [    4.464020] 1-001a supply DBVDD not found, using dummy regulator
Apr  5 01:51:00 raspberrypi kernel: [    4.470348] usbcore: registered new interface driver brcmfmac
Apr  5 01:51:00 raspberrypi kernel: [    4.470773] audioinjector-audio soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
Apr  5 01:51:00 raspberrypi kernel: [    4.470785] audioinjector-audio soc:sound: snd_soc_register_card failed (-517)
Apr  5 01:51:00 raspberrypi kernel: [    4.481136] audioinjector-audio soc:sound: wm8731-hifi <-> 3f203000.i2s mapping ok
Apr  5 01:51:00 raspberrypi kernel: [    4.638186] brcmfmac: Firmware version = wl0: May 27 2016 00:13:38 version 7.45.41.26 (r640327) FWID 01-df77e4a7
Image
Image
Image
Image


Any tips?
Thank's!

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Wed Apr 05, 2017 9:13 pm

Hi there,

It seems it may be a mixer problem.
In alsamixer :
The "Output Mixer HiFi" to the right of the "Input Mux" should be enabled.

Can you confirm that your mixer is set up in a similar manner to the following mixers ?
viewtopic.php?f=5&t=3&start=15

thanks
Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

rod_amaral
Posts: 3
Joined: Wed Apr 05, 2017 12:01 pm

Re: How to setup and test

Post by rod_amaral » Thu Apr 06, 2017 12:49 am

Thank you Matt!

Playback worked perfectly! However, i can't set the capture for RCA input or Microphone.

On the other controls I was able to use the M, Up and Down keys to change the values. Which key should I use to select capture?

Thanks again!

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Fri Apr 07, 2017 7:56 am

For capture, press F4 or tab to go to the capture section.
There are posts on this forum for how to set the alsamixer for capture from either the microphone or the line inputs.

thanks
Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

rod_amaral
Posts: 3
Joined: Wed Apr 05, 2017 12:01 pm

Re: How to setup and test

Post by rod_amaral » Sat Apr 08, 2017 5:57 am

Thank you! It worked perfectly!

abonam
Posts: 20
Joined: Sat May 13, 2017 7:21 am

Re: How to setup and test

Post by abonam » Sun May 14, 2017 6:15 am

Hello,
I ran into the two following issues after installing the AudioInjector:

1) I downloaded got the latest Raspbian Jessie distribution on my Pi3, followed the manual setup to install audioInjector card (sudo rpi-update, disabled PWM audio, added the dtoverlay=audioinjector-wm8731-audio line to the config.txt) then rebooted the system.
When I reboot, the wi-fi card is disabled, I was wondering if this is an issue with my configuration. Wi-fi access is needed by my project.

2) I was not able to see the audio injector at all, the command aplay-l returned error. I am attaching the output of the command dimes.


Thank you in advance for your help!

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Fri May 19, 2017 8:23 am

CAn you please send the output from dmesg ?
lets see if the card is found.
Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest