How to setup and test

Moderator: flatmax

medeiran
Posts: 5
Joined: Sun May 21, 2017 2:26 pm

Re: How to setup and test

Post by medeiran » Sun May 21, 2017 2:37 pm

Bought the sound card with in-built microphone off of Amazon and have been trying to install it for the last couple days without luck. When I try to play an audio file off an attached USB hard drive using aplay, I get an unending run of loud static through a set of headphones attached to the headphone jack on the soundcard. (Runs much longer than the song would otherwise run.) When I try to play the same audio file using omxplayer, the file plays properly through the monitor attached to the hdmi port and/or headphones through the Pi's headphone jack, depending on the option chosen.

Any guidance would be greatly appreciated. Thanks!

medeiran
Posts: 5
Joined: Sun May 21, 2017 2:26 pm

Re: How to setup and test

Post by medeiran » Sun May 21, 2017 2:48 pm

Tried to post this a few minutes ago, but it doesn't seem to have gone through. (So I apologize up front if I end up double-posting.)

I'm trying to set up the Sound Car with In-Built microphone on a new Pi3. I went through the automatic process and now when I try to play audio files off an attached USB Drive using aplay, I get an endless string of static through a set of headphones in the jack on the sound card. When I run the same files through omxplayer, the audio is played through the HDMI and/or the headphone jack on the Pi itself.

Don't know what I'm missing. Appreciate any feedback.
Thanks!

flatmax
Posts: 604
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Mon May 22, 2017 7:15 pm

I am wondering whether your /boot/config.txt is setup correctly ... can you post it or the audio realted part here ?
thanks
Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

medeiran
Posts: 5
Joined: Sun May 21, 2017 2:26 pm

Re: How to setup and test

Post by medeiran » Tue May 23, 2017 10:44 am

flatmax wrote:I am wondering whether your /boot/config.txt is setup correctly ... can you post it or the audio realted part here ?
thanks
Matt
Here's the full /boot/config.txt.

Code: Select all

# For more options and information see
# http://rpf.io/configtxtreadme
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
#dtparam=audio=on

# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1
# enable the AudioInjector.net sound card
	dtoverlay=audioinjector-wm8731-audio


flatmax
Posts: 604
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Tue May 23, 2017 4:29 pm

The thing which is confusing for me is that your headphone jack on the pi should not be enabled neither should HDMI !
For example, if my /boot/config.txt file only has the following line :

Code: Select all

dtoverlay=audioinjector-wm8731-audio
Then when I look at the available sound cards (with the command aplay -l), I will only see the Audioinjector :

Code: Select all

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: audioinjectorpi [audioinjector-pi-soundcard], device 0: AudioInjector audio wm8731-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
When you hear output through your HDMI or headphone jack on the pi, then your aplay -l command must list these other deivces, can you see them ?

thanks
Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

medeiran
Posts: 5
Joined: Sun May 21, 2017 2:26 pm

Re: How to setup and test

Post by medeiran » Tue May 23, 2017 9:43 pm

flatmax wrote:When you hear output through your HDMI or headphone jack on the pi, then your aplay -l command must list these other deivces, can you see them ?
Looks like I've got the same list of devices as you.

Code: Select all

pi@raspberrypi:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: audioinjectorpi [audioinjector-pi-soundcard], device 0: AudioInjector audio wm8731-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

flatmax
Posts: 604
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Wed May 24, 2017 8:32 am

Still a little bit stumped as to why the HDMI and Pi's headphone jack are playing audio ?! Their audio devices don't exist.
Can you please contact me off list ? PM me here, of if you have my email address, send directly there.

thanks
Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

flatmax
Posts: 604
Joined: Sat Jul 23, 2016 11:39 pm

Re: How to setup and test

Post by flatmax » Wed May 24, 2017 11:49 am

I have an idea.
Can you try to play the USB audio files using aplay again ?
This time, use the plug:dmix device, should be something like :
aplay -Dplug:dmix audiofile
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

medeiran
Posts: 5
Joined: Sun May 21, 2017 2:26 pm

Re: How to setup and test

Post by medeiran » Wed May 24, 2017 9:31 pm

Tried this (replacing the "audiofile" with the path of my file) and got the same static sound.

Code: Select all

aplay -Dplug:dmix audiofile

repellent germ
Posts: 1
Joined: Thu May 18, 2017 8:18 am

Re: How to setup and test

Post by repellent germ » Tue Jun 06, 2017 2:47 am

Hi,
I've tried both manual setup and installing the deb file and both have given the same results........ I am only getting sound through the headphone socket. does anyone have any suggestions? thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests