Page 8 of 14

Re: How to setup and test

Posted: Thu Nov 02, 2017 6:56 pm
by Denny9167
Any suggestions on setting it up on Ubuntu Mate, there seems to be more settings in the boot/config.txt device tree, than found in Raspbian. Thanks

Re: How to setup and test

Posted: Sat Nov 04, 2017 1:01 pm
by flatmax
Can you point me to the ubuntu mate linux repo online ?

thanks
MAtt

Re: How to setup and test

Posted: Sun Nov 05, 2017 9:13 am
by Denny9167
https://ubuntu-mate.org/blog/ubuntu-mat ... erry-pi-3/

I believe it’s 16.0, apologies should have posted that

Re: How to setup and test

Posted: Sun Nov 05, 2017 9:55 am
by Denny9167
I did a setup in Raspbian and it seemed to install correctly, but I wasn’t happy with the OS it was a little slow,and just didn’t like the interface. I looked into Ubuntu and found The MATE desktop and it looked like it would something to try, and after I installed it and played with it for a few hours, realized how much more this offered in the way of apps and ease of upgrading, and believe it or not responded faster than the Raspbian did, BTW I’m using and RPi 3 model B.

Re: How to setup and test

Posted: Tue Nov 07, 2017 11:19 am
by jessecobra
Can I install this audio card on a "headless" Raspberry Pi Zero W. I do not use the monitor with my device at all, just network SSH login...

Thanks!
Jesse

Edit: Nevermind, just saw this on the original post:

Manual setup method
Ensure you have the latest kernel : sudo rpi-update
Make sure the default audio device tree is not loaded for PWM output (/boot/config.txt), this is because it uses the same I2S bus. (Comment out dtparam=audio=on)
Make sure the Audio Injector device tree is loaded at boot time : dtoverlay=audioinjector-wm8731-audio
Reboot to force the correct device tree to load.

Then I also had to run:
alsactl --file asound.state.RCA.thru.test restore

Which contained:

Code: Select all

pi@raspberrypi:~$ cat asound.state.RCA.thru.test 
state.audioinjectorpi {
        control.1 {
                iface MIXER
                name 'Master Playback Volume'
                value.0 121
                value.1 121
                comment {
                        access 'read write'
                        type INTEGER
                        count 2
                        range '0 - 127'
                        dbmin -9999999
                        dbmax 600
                        dbvalue.0 0
                        dbvalue.1 0
                }
        }
        control.2 {
                iface MIXER
                name 'Master Playback ZC Switch'
                value.0 false
                value.1 false
                comment {
                        access 'read write'
                        type BOOLEAN
                        count 2
                }
        }
        control.3 {
                iface MIXER
                name 'Capture Volume'
                value.0 23
                value.1 23
                comment {
                        access 'read write'
                        type INTEGER
                        count 2
                        range '0 - 31'
                        dbmin -3450
                        dbmax 1200
                        dbvalue.0 0
                        dbvalue.1 0
                }
        }
        control.4 {
                iface MIXER
                name 'Line Capture Switch'
                value.0 true
                value.1 true
                comment {
                        access 'read write'
                        type BOOLEAN
                        count 2
                }
        }
        control.5 {
                iface MIXER
                name 'Mic Boost Volume'
                value 0
                comment {
                        access 'read write'
                        type INTEGER
                        count 1
                        range '0 - 1'
                        dbmin 0
                        dbmax 2000
                        dbvalue.0 0
                }
        }
        control.6 {
                iface MIXER
                name 'Mic Capture Switch'
                value false
                comment {
                        access 'read write'
                        type BOOLEAN
                        count 1
                }
        }
        control.7 {
                iface MIXER
                name 'Sidetone Playback Volume'
                value 0
                comment {
                        access 'read write'
                        type INTEGER
                        count 1
                        range '0 - 3'
                        dbmin -1500
                        dbmax -600
                        dbvalue.0 -1500
                }
        }
        control.8 {
                iface MIXER
                name 'ADC High Pass Filter Switch'
                value true
                comment {
                        access 'read write'
                        type BOOLEAN
                        count 1
                }
        }
        control.9 {
                iface MIXER
                name 'Store DC Offset Switch'
                value false
                comment {
                        access 'read write'
                        type BOOLEAN
                        count 1
                }
        }
        control.10 {
                iface MIXER
                name 'Playback Deemphasis Switch'
                value false
                comment {
                        access 'read write'
                        type BOOLEAN
                        count 1
                }
        }
        control.11 {
                iface MIXER
                name 'Output Mixer Line Bypass Switch'
                value false
                comment {
                        access 'read write'
                        type BOOLEAN
                        count 1
                }
        }
        control.12 {
                iface MIXER
                name 'Output Mixer Mic Sidetone Switch'
                value false
                comment {
                        access 'read write'
                        type BOOLEAN
                        count 1
                }
        }
        control.13 {
                iface MIXER
                name 'Output Mixer HiFi Playback Switch'
                value true
                comment {
                        access 'read write'
                        type BOOLEAN
                        count 1
                }
        }
        control.14 {
                iface MIXER
                name 'Input Mux'
                value 'Line In'
                comment {
                        access 'read write'
                        type ENUMERATED
                        count 1
                        item.0 'Line In'
                        item.1 Mic
                }
        }
}
Thank you to who ever made this card! What an awesome and valuable audio platform!

Now I just need to figure out why my audio app which ran fine on the armv7 Pi does not work properly on this armv6 Pi Zero!

I keep forgetting its such a lower end and older processor arch.... Lacks NEON even!

Re: How to setup and test

Posted: Tue Nov 14, 2017 11:05 am
by joe_h
I have seen a few posts in this thread on people having the soundcard wired up properly, but the sound still playing through the hdmi on the raspberry pi. Was there a fix to this?

I have a brand new raspberry pi3 and just bought the stereo soundcard off of Amazon. I did the automated setup and everything is showing correctly in the config.txt and when I do a aplay -l. However, no sound comes out of the soundcard and all comes through the hdmi.

Below is everything you asked from others to post. Also, I tried the sudo alsactl store command for saving my alsamixer settings, but every time I go back in there the capture option is turned off.

Any help would be greatly appreaciated.

Code: Select all

# Enable audio (loads snd_bcm2835)
#dtparam=audio=on

# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1
# enable the AudioInjector.net sound card
	dtoverlay=audioinjector-wm8731-audio

Code: Select all

pi@jhurst:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: audioinjectorpi [audioinjector-pi-soundcard], device 0: AudioInjector audio wm8731-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
  
Image

Re: How to setup and test

Posted: Tue Nov 14, 2017 11:12 am
by joe_h
I just entered a detailed post, but I do not see it on the forum.

In brief it showed everything you have been asking others with the config.txt, the aplay-l and the alsamixer settings correct, minus the capture setting. As I mentioned it kept turning off on me and I couldn't get the sudo alsactl store command to actually save anything.

I am getting audio through the hdmi on the raspberry pi but not the stereo card.

Any help would be greatly appreaciated

Re: How to setup and test

Posted: Thu Nov 16, 2017 8:35 pm
by flatmax
joe_h wrote:
Tue Nov 14, 2017 11:05 am
I have seen a few posts in this thread on people having the soundcard wired up properly, but the sound still playing through the hdmi on the raspberry pi. Was there a fix to this?

I have a brand new raspberry pi3 and just bought the stereo soundcard off of Amazon. I did the automated setup and everything is showing correctly in the config.txt and when I do a aplay -l. However, no sound comes out of the soundcard and all comes through the hdmi.

Below is everything you asked from others to post. Also, I tried the sudo alsactl store command for saving my alsamixer settings, but every time I go back in there the capture option is turned off.

Any help would be greatly appreaciated.

Code: Select all

# Enable audio (loads snd_bcm2835)
#dtparam=audio=on

# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1
# enable the AudioInjector.net sound card
	dtoverlay=audioinjector-wm8731-audio

Code: Select all

pi@jhurst:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: audioinjectorpi [audioinjector-pi-soundcard], device 0: AudioInjector audio wm8731-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
  
Image
Hi there,

Interesting problem !
The thing is that ALSA is saying that you have only one sound device installed - the Audio Injector sound card. It seems a little strange that it is playing through HDMI.

Have you tried removing any non-necessary HDMI lines from the boot.txt file ?

Matt

Re: How to setup and test

Posted: Fri Dec 01, 2017 1:19 am
by stupid.stupido
Hello

I know that this is not the real place for asking it in this forum i am sorry, but i dont see it anymore at the moment. Maybe someone can help me::

I stuck in installing the deb file. I use debtap on archlinux to convert it into AUR package.

when I use

>> debtap audio.injector.scripst_0.1-all.deb

i get:
>> xz: audio.injector.scripts-0.1-1-any.pkg.tar: Cannot allocate memory
>> mv: cannot stat '*.xz': No such file or directory

is there an alternative to install it on Arch-linux? Or any further advices?

Thx in advance.

Re: How to setup and test

Posted: Fri Dec 01, 2017 2:56 am
by stupid.stupido
Hello

maybe somone can help me or give me an advice:

i want to install a .deb package (audio.injector.scripts_0.1-1_all.deb) using

Code: Select all

debtap
but it seems that there is a problem when debtap is creating the pkg.tar out of the .deb file:

input:

Code: Select all

root@alarm>> debtap audio.injector.scripts_0.1-1_all.deb
root@alarm>> 


output:

Code: Select all

==> Extracting package data...
==> Fixing possible directories structure differencies...
==> Generating .PKGINFO file...

:: Enter Packager name:


:: Enter package license (you can enter multiple licenses comma separated):


*** Creation of .PKGINFO file in progress. It may take a few minutes, please wait...

==> Checking and generating .INSTALL file (if necessary)...
grep: tempfile2: No such file or directory
grep: tempfile2: No such file or directory


:: If you want to edit .PKGINFO file, press (1) For vi (2) For nano (3) For default editor (4) For a custom editor or any other key to continue:

==> Generating .MTREE file...

==> Creating final package...
xz: audio.injector.scripts-0.1-1-any.pkg.tar: Cannot allocate memory
mv: cannot stat '*.xz': No such file or directory
==> Package successfully created!
==> Removing leftover files...


At the end I dont have the *.pkg.tar.xz file


Thx in advance