Page 1 of 1

Click at start of mic recording

Posted: Wed Aug 02, 2017 7:16 am
by duncanh
Hello

Everything seems to be set up and working well except I get an audible click when recording from my mic. It's a small electret soldered to a wire approx 30cm long connected to a screw terminal which I soldered to the board. The click lasts for approx. 0.75 seconds and then the rest of the recording is fine.

I've tried this recording with the python app which I'm creating and using arecord and both give the click at all sample rates I've tested.
If I record from line in there's no click.

For my app I was always planning to use a callback function for non-blocking recording and I can currently avoid the click by having the callback wait approx 0.75 seconds until it actually starts sending the stream to the file. This work around does get avoid the problem but I was wondering why it happens and is there a way to avoid it.

Thanks

(also, I tried searching but 'click' is apparently too common a word and the search fails. Sevearl other searches I tried this evening, including line also fail because the word is too common. Any way to make the search function useful?)

Re: Click at start of mic recording

Posted: Tue Aug 08, 2017 9:27 pm
by flatmax
Hi there,

Is the alsamixer "Output Mixer Mic Sidetone" switch what you are after ?
In the following audacity image, you can see two microphone recordings one with the sidetone disabled (default) and the bottom one with the sidetone enabled.
You will notice the initial impulse is missing in the bottom one - which is what (I think) you are after ? The alsamixer setting with this enabled is shown below as well.
audioinjector.sound.raspberry.pi.mic.SideTone.jpg
Removing mic recording initial impulse
audioinjector.sound.raspberry.pi.mic.SideTone.jpg (233.79 KiB) Viewed 2475 times
Audio.injector.raspberry.pi.sound.mic.sidetone.alsamixer.jpg
Alsamixer setting to enable the output mixer mic. sidetone
Audio.injector.raspberry.pi.sound.mic.sidetone.alsamixer.jpg (103.34 KiB) Viewed 2475 times
Matt

Re: Click at start of mic recording

Posted: Wed Aug 09, 2017 8:10 am
by duncanh
Thanks. I'm away until next week but will try it when I get back