Line input streaming is slow downpitched

Moderator: flatmax

Post Reply
Username
Posts: 4
Joined: Thu Feb 09, 2017 11:12 am

Line input streaming is slow downpitched

Post by Username » Thu Feb 09, 2017 11:25 am

Hi, I'm trying to stream from the input and I can hear the music but it's like the speed of the music is about 25% of the normal speed. I've tried this with the wave input plugin with logitech media server and squeezelite and also with icecast2-liquidsoap. I've also tried:
arecord -f S32_LE -c 2 -r 96000 /tmp/test.wav
but i get:
Recording WAVE '/tmp/test.wav' : Signed 32 bit Little Endian, Rate 96000 Hz, Stereo
arecord: set_params:1297: Unable to install hw params:
ACCESS: RW_INTERLEAVED
FORMAT: S32_LE
SUBFORMAT: STD
SAMPLE_BITS: 32
FRAME_BITS: 64
CHANNELS: 2
RATE: 96000
PERIOD_TIME: (125011 125012)
PERIOD_SIZE: [12001 12001]
PERIOD_BYTES: (96008 96016)
PERIODS: (3 4)
BUFFER_TIME: (500041 500042)
BUFFER_SIZE: 48004
BUFFER_BYTES: 384032
TICK_TIME: 0


I was able to record a sample with this command:
arecord --duration=30 -vvvv -f cd --file-type wav test.wav

In alsamixer, if I hit the bypass the audio plays normally, but I'm looking for the processed audio not the bypass.

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: Line input streaming is slow downpitched

Post by flatmax » Sun Feb 12, 2017 7:40 pm

Hi there,

This is very strange behaviour. The AI sound card is capable of your specifications, 96kHz, 32 bit LE, and two channels. Not sure why it is complaining.
How did you install your driver and is it the latest version ? Do you have any asoundrc files doing anything strange ?

thanks
Matt
Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

Username
Posts: 4
Joined: Thu Feb 09, 2017 11:12 am

Re: Line input streaming is slow downpitched

Post by Username » Tue Feb 14, 2017 1:11 am

I installed the drivers last week with the debian package as I wanted to use it with max2play. Maybe I did not instal them properly? There wasn't any instruction on your site on how to install the debian package. Anyhow it's funny that I can stream music of a disk drive or radio station but not from the analogue input.

I installed max2play image first and then the debian package for the AI soundcard. Finally, logitech media server within the max2play interface. As for liquidsoap and icecast2 these were installed outside of max2play with command lines.
Do you have any asoundrc files doing anything strange
I don't know how to check for that. I'm a newbie with Linux and programming.

One additional thing is that when I try to use the output: hw, plughw I hear this slowed pitch music but I cannot select dmix or dsnoop, I get the following error: output_init_common:382 unable to open output device

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: Line input streaming is slow downpitched

Post by flatmax » Tue Feb 14, 2017 5:51 am

Can you please post here the commands you are using, perhaps I can give you some guidance regarding using dmix for output and dsnoop for input.

thanks
Matt
Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

Username
Posts: 4
Joined: Thu Feb 09, 2017 11:12 am

Re: Line input streaming is slow downpitched

Post by Username » Tue Feb 14, 2017 9:18 am

After a fresh reinstall of everything Icecast2 with Liquidsoap now streams perfectly from the input. I've tried waveinput plugin in Logitech Media Server (Squeezebox Server) and it still gives me the slow down-pitch music. I've come to the conclusion that there is something not working well with wave input and I'll simply not use it. Thanks for your responses/help.

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: Line input streaming is slow downpitched

Post by flatmax » Tue Feb 14, 2017 1:27 pm

OK, glad that you have diagnosed this problem with Logitech's wave input.

Best of luck !
Matt
Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests