Alsamixer Master doesn't control line out

Moderator: flatmax

Post Reply
terry1769
Posts: 6
Joined: Tue Oct 24, 2017 10:08 am

Alsamixer Master doesn't control line out

Post by terry1769 » Thu May 24, 2018 4:17 am

Hi,
I have the audioinjector zero card attached to a Pi zero w. I'm using it in an application where I need to control volume in and volume out by code so using the pots isn't workable. I've found that I have no control over Volume Out. In Alsamixer I can run "Master" all the way to the top or bottom and the sound always stays at full volume. If I use the attached headphone outlet Master controls volume as expected. Is there a way around this or do I just need to attach to the headphone port for my output?

terry1769
Posts: 6
Joined: Tue Oct 24, 2017 10:08 am

Re: Alsamixer Master doesn't control line out

Post by terry1769 » Wed Jun 06, 2018 11:13 pm

2 weeks and 65 views and not a single answer from the mods. And they just sent me a notice that they're launching a new product. Yeah, I think I'll skip that one. :(

flappix
Posts: 2
Joined: Sat Jul 07, 2018 2:16 am

Re: Alsamixer Master doesn't control line out

Post by flappix » Sat Jul 07, 2018 2:20 am

Same problem here.

Using the volume controls from jack application seems to work so it's not too bad for me. But of course that's not always possible so a fix / hint for problem solving would be very nice.

moggyd
Posts: 22
Joined: Wed Jul 05, 2017 5:09 pm

Re: Alsamixer Master doesn't control line out

Post by moggyd » Wed Jul 25, 2018 11:24 am

Take a look here:

https://unix.stackexchange.com/question ... m-terminal

You can use amixer to change most of the settings on the fly.

Don't install/use the pots - they just introduce noise.

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests