Page 1 of 1

Alsamixer Master doesn't control line out

Posted: Thu May 24, 2018 4:17 am
by terry1769
Hi,
I have the audioinjector zero card attached to a Pi zero w. I'm using it in an application where I need to control volume in and volume out by code so using the pots isn't workable. I've found that I have no control over Volume Out. In Alsamixer I can run "Master" all the way to the top or bottom and the sound always stays at full volume. If I use the attached headphone outlet Master controls volume as expected. Is there a way around this or do I just need to attach to the headphone port for my output?

Re: Alsamixer Master doesn't control line out

Posted: Wed Jun 06, 2018 11:13 pm
by terry1769
2 weeks and 65 views and not a single answer from the mods. And they just sent me a notice that they're launching a new product. Yeah, I think I'll skip that one. :(

Re: Alsamixer Master doesn't control line out

Posted: Sat Jul 07, 2018 2:20 am
by flappix
Same problem here.

Using the volume controls from jack application seems to work so it's not too bad for me. But of course that's not always possible so a fix / hint for problem solving would be very nice.

Re: Alsamixer Master doesn't control line out

Posted: Wed Jul 25, 2018 11:24 am
by moggyd
Take a look here:

https://unix.stackexchange.com/question ... m-terminal

You can use amixer to change most of the settings on the fly.

Don't install/use the pots - they just introduce noise.