New Stereo soundcard, no sound through RCA input.. Any help appreciated.

Moderator: flatmax

Post Reply
UFO-Rpi3b5000
Posts: 2
Joined: Wed Oct 31, 2018 1:00 am

New Stereo soundcard, no sound through RCA input.. Any help appreciated.

Post by UFO-Rpi3b5000 » Wed Oct 31, 2018 1:44 am

I only just recently brought the Audio Injector Stereo Soundcard, to try to boost the dud sound quality of the Rpi 3B.Though still a week later I am unable to get it to play any sound out of the RCA output like it should. However I had some luck getting it to play through the headphone jack w/ a set of headphones. Please give me any advice you can, I don't want to have to listen to my Pi through the headphones all the time lol!
I'll try to post a screen of the aplay -l, dmesg | grep "audio" & my alsamixer results. I appreciate any support.. Cheers

dietslurm
Posts: 6
Joined: Sat May 19, 2018 10:24 am

Re: New Stereo soundcard, no sound through RCA input.. Any help appreciated.

Post by dietslurm » Tue Nov 06, 2018 3:39 pm

This'll do it. I came back to this forum because I had the same problem and somebody told me what to do, and it worked. I just finally got around to a full "production" test tonight. So, whoever it was that helped me so many months ago, thanks. I presently can't find the file that would have had the info on who to properly credit. Sorry. Mea culpa maxima.

Before you try to get the RCA inputs to work, do this:

/usr/sbin/alsactl --file /usr/share/doc/audioInjector/asound.state.RCA.thru.test restore

Since I'm running a C++ program, I insure that I do this by calling system() w/ the right stuff.

BTW -- i believe the card/HAT reverts to using the default inputs every chance it gets, so don't be surprised if you have to keep doing this. Mine was stable for 3 hours in my production test.

j.

Lexridge
Posts: 2
Joined: Mon Nov 19, 2018 11:54 am

Re: New Stereo soundcard, no sound through RCA input.. Any help appreciated.

Post by Lexridge » Mon Nov 19, 2018 12:32 pm

I was having sound issues [no sound] after installing a realtime kernel. This method fixed it! Thank you so much!

murphyj03
Posts: 2
Joined: Sat Dec 15, 2018 9:33 am

Re: New Stereo soundcard, no sound through RCA input.. Any help appreciated.

Post by murphyj03 » Wed Dec 19, 2018 11:28 am

I am having the same same issue, no sound through RCA input. I changed the alsamixer settings using the script, but still no luck.

/usr/sbin/alsactl --file /usr/share/doc/audioInjector/asound.state.RCA.thru.test restore <-- didn't fix it for me!!!

Any ideas? The on board mic works, but when I change input to Line-in, there is no audio captured on the external mic. I have tried several mics and cables, so the issue seems to be with the sound card setup. Any help is appreciated.

curiousgeorge
Posts: 2
Joined: Sun Feb 03, 2019 2:16 am

Re: New Stereo soundcard, no sound through RCA input.. Any help appreciated.

Post by curiousgeorge » Sun Feb 03, 2019 2:21 am

Same issue for me. Ran deb file, entered alsoctl for RCA, etc. No joy. Mic works fine, output fine, everything seems to be great but no audio input through RCA. I am direct injecting audio into the zero card (AC coupled @1Vpp), i.e. not using the off-board RCA input. Nothing but some slight "hiss" that interestingly can be increased with gain on the alsamixer. Any clues as to why the non-mic audio input is not working are appreciated!

curiousgeorge
Posts: 2
Joined: Sun Feb 03, 2019 2:16 am

Re: New Stereo soundcard, no sound through RCA input.. Any help appreciated.

Post by curiousgeorge » Wed Feb 06, 2019 6:29 am

After some experimentation, it appears (at least for the Zero board I got from Amazon) that if ALSA is used for configuration then setting "MIC" for the input mux selector, then BOTH mic and line-in are enabled. If setting "Line In" for the input mux selector, then neither mic or line in are enabled. So, is ALSA talking to the WM8731 chip as expected? Maybe not. In any case, a simple but not-so-elegant solution to using the Zero's line-in inputs is to choose (and execute) the ".MIC." version of the alsactl configuration file and disconnect the microphone from the Zero board. I doubt there is any hardware problem with my Zero board as I can use alsamixer to enable "bypass" and the audio being injected to the "line-in" inputs can be heard nicely on the audio output... conclusion, the WM8731 input mux is not being set as expected by ALSA.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests