Disabling ON-Board Microphone

Moderator: flatmax

Post Reply
PGoldie
Posts: 4
Joined: Mon Mar 26, 2018 11:47 am

Disabling ON-Board Microphone

Post by PGoldie » Mon Dec 31, 2018 6:54 pm

How? I'm getting feedback when I play my monitors at 11.

colinbrogan
Posts: 7
Joined: Sat Dec 15, 2018 10:34 am

Re: Disabling ON-Board Microphone

Post by colinbrogan » Sun Jan 06, 2019 12:34 pm

How are you setting the alsamixer settings? I run this command at startup:

Code: Select all

alsactl --file ~/asound.state.RCA.thru.test restore
It has the following lines, which I believe disables microphone input

Code: Select all

	control.5 {
		iface MIXER
		name 'Mic Boost Volume'
		value 0
		comment {
			access 'read write'
			type INTEGER
			count 1
			range '0 - 1'
			dbmin 0
			dbmax 2000
			dbvalue.0 0
		}
	}
	control.6 {
		iface MIXER
		name 'Mic Capture Switch'
		value false
		comment {
			access 'read write'
			type BOOLEAN
			count 1
		}
You can get the file for alsactl settings here:
https://github.com/Audio-Injector/stere ... .thru.test

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests