Loud click / crackle noise when switching guitarix effects

Moderator: flatmax

Post Reply
AIRossi
Posts: 1
Joined: Tue Jan 29, 2019 6:03 pm

Loud click / crackle noise when switching guitarix effects

Post by AIRossi » Tue Jan 29, 2019 6:19 pm

Hi,
I experience very loud clicking/crackling noise when I switch on/off sound effects in Guitarix.
My setup:
Raspberry Pi 3 Model B
Zynthian Gorgona (Based on Raspbian / Debian 8 Jessie)
Kernel 4.9.35-v7+ #1014 SMP
Audio Injector Stereo Sound Card
jackd 1.9.10

/usr/bin/jackd -T -ndefault -u -dalsa -r48000 -p128 -n4 -s -m -S -H -D -Chw:audioinjectorpi,0 -Phw:audioinjectorpi,0

Changes to sample rate, frames/period and periods/buffer do not help.

Code: Select all

lsmod|grep snd
snd_seq_dummy           1883  0 
snd_seq_midi            5353  1 
snd_seq_midi_event      7462  1 snd_seq_midi
snd_seq                61740  8 snd_seq_midi_event,snd_seq_dummy,snd_seq_midi
snd_usb_audio         147900  1 
snd_hwdep               6688  1 snd_usb_audio
snd_usbmidi_lib        22487  1 snd_usb_audio
snd_rawmidi            23790  2 snd_seq_midi,snd_usbmidi_lib
snd_seq_device          5504  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_soc_wm8731         14257  1 
snd_soc_bcm2835_i2s     6546  2 
snd_soc_audioinjector_pi_soundcard     4782  0 
snd_soc_core          179915  3 snd_soc_wm8731,snd_soc_bcm2835_i2s,snd_soc_audioinjector_pi_soundcard
snd_compress           10384  1 snd_soc_core
snd_pcm_dmaengine       5894  1 snd_soc_core
snd_pcm                98501  7 snd_soc_wm8731,snd_usb_audio,snd_pcm_dmaengine,snd_soc_core,snd_soc_audioinjector_pi_soundcard
snd_timer              23968  2 snd_seq,snd_pcm
snd                    70032  17 snd_soc_wm8731,snd_compress,snd_hwdep,snd_seq,snd_usb_audio,snd_timer,snd_rawmidi,snd_usbmidi_lib,snd_seq_device,snd_soc_core,snd_pcm
The noise occurs on any effect plugin (ladspa and lv2). It happens when I run guitarix with or without GUI and regardless of the way I toggle the effect (Midi footswitch or Mouse)

I wanted to use the pi with the AudioInjector Card as a multi effect machine. I tested the same software setup with a Behringer USB Audio Interface and did not get any noise. Unfortunately the jackd crashes from time to time when using many effects via USB.
The AudioInjector setupt runs perfectly stable over many days but is not usable with this noise.

Any help apreciated.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests