Lightshowpi issues

Moderator: flatmax

Post Reply
Posts: 1
Joined: Sat Mar 02, 2019 5:52 am

Lightshowpi issues

Post by TheRobbitt » Sat Mar 02, 2019 6:16 am

I just got the stereo card working and am trying to use it with Lightshowpi.
I am not sure what is going on. I get an alsaaudio.ALSAAudioError: Input/output error

My guess is the Lightshowpi program is not seeing the AudioInjector card. In the program there is a setting for an audio in and audio out card. I get the above error for the default audio card setting and everything else that appears to be the name ( such as audioinjector-pi ) that I've put in there gives me a "no such device".

The Lightshowpi worked with the orignal RP3 setup.

There is an asound.conf within Lightshowpi:

pcm.!default {
type file #File PCM
slave.pcm "hw:0,0" #This should match the playback device at /proc/asound/devices
file /tmp/audio #Output filename
format raw #File format ("raw or wav")
perm 0777 # Output file permission (octal, def. 0777)

And at /proc/asound/devices I have:
0: [ 0] : control
16: [ 0- 0] : digital audio playback
24: [ 0- 0] : digital audio capture
33: : timer

Completely lost, nothing I've tried has worked. Any help is greatly appreciated.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest