RCA input not working

Moderator: flatmax

Post Reply
slampus
Posts: 4
Joined: Thu Jan 19, 2017 3:56 am

RCA input not working

Post by slampus » Thu Jan 19, 2017 6:03 am

Hi! I have a problem with my board, when i plug in the RCA in i get no passthrough.
Im running rasbian normal build.

I have tried to config with alsamixer but tried everything and still not getting any passthrough.

Thankfull for help!

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: RCA input not working

Post by flatmax » Thu Feb 02, 2017 7:27 pm

Hi there,

First of all lets get your system into a state which sets up the line inputs as active and the microphone as inactive. IF you installed my .deb package to help you setup then you can run the following command to make this happen :
alsactl --file /usr/share/doc/audioInjector/asound.state.RCA.thru.test restore

Now that your line inputs are selected and the output is enabled, you will want to set the Output Micer Line Bypass. Start alsa mixers, highlight that control and press "m" , the control should go green with "00" inside.
Another way to do this is to run the following command :
amixer sset 'Output Mixer Line Bypass' off

Hope that helps
Matt
Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

slampus
Posts: 4
Joined: Thu Jan 19, 2017 3:56 am

Re: RCA input not working

Post by slampus » Fri Feb 03, 2017 1:36 am

Sorry, wrote this long time ago. It was just the Alsamixer settings i was setting wrong, now it works.
Thanks!

Ben
Posts: 3
Joined: Wed Feb 08, 2017 9:08 am

Re: RCA input not working

Post by Ben » Wed Feb 08, 2017 9:21 am

Hello everyone,
My RCA input is also not working. The configuration for the bypass in alsamixer works fine. But when I try to record something there is no signal. I tried it with the pi3 and the new Pixel Raspian and also on raspina lite with Audacity. On both OS versions I can chose the AI soundcard (without microfon) for recording in the dropw down menu in Audacity, but I don't get a signal there. With a USB-soundcard it works without any issues. I want to use the AI card also for xwax, there the same problem.
I installed on both systems as said in "How to setup and test"

And ran alsactl --file /usr/share/doc/audioInjector/asound.state.RCA.thru.test restore severel times.

The audioInjector-test.sh runs without a gui as shown in your picture and I don't know if there is everything right.

I tested the card with the pideck-distro there it is working. The distro is nice for xwax soo, but very limited to some other use cases.
Anyone an idea?
Thanks in advance!

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: RCA input not working

Post by flatmax » Wed Feb 08, 2017 2:47 pm

Hey Ben, lets try to get this working.

To get the line inputs working please do the following :
1] Ensure potentiometer is clockwise.
2] Plug RCA lines into the connectors between the headphone jack and the network socket.
3] Set the alsamixer to have "CAPUTRE" above the Line input, Capture volume up and Input Mux to "Line In".

This command should work :
arecord -f S32_LE -c 2 -r 96000 /tmp/test.wav
audioInjector.line.alsamixer.png
Audio Injector alsamixer setup for line recording
audioInjector.line.alsamixer.png (41.56 KiB) Viewed 20987 times
Hope that helps
Matt
Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

Ben
Posts: 3
Joined: Wed Feb 08, 2017 9:08 am

Re: RCA input not working

Post by Ben » Thu Feb 09, 2017 5:10 am

Hey Matt,

thanks for the quick answer. I missed to set the capture mode in alsamixer. So recording (with Audacity) now works on both OSs Pixel raspian and raspian lite.
Thanks!
But it seems that the settings are not saved. I tried alsactl store, but after rebooting capture mode isn't set anymore.
And I have also no reaction when I try to run xwax.
I start it with:

Code: Select all

xwax -l /media/usb0/Music/ -a hw:0
It is starting up, but no signal. Has anyone an idea?
Same with pideck. There I get the message:
Initialising deck 0 (hw:0)...
ALSA hw_params: Invalid argument
Failed to open device for capture.
Which ALSA hw_params are right and where to find it?

Thanks in advance!

Ben

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: RCA input not working

Post by flatmax » Thu Feb 09, 2017 9:53 am

I am not sure about xwax. They were having trouble getting the latencies down to expected levels ... hmmm.
I wonder whether you need the mmap option enabled in the boot config.txt. This message will tell you how to enable mmap support :
viewtopic.php?f=5&t=16

thanks
Matt
Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

Ben
Posts: 3
Joined: Wed Feb 08, 2017 9:08 am

Re: RCA input not working

Post by Ben » Sat Feb 11, 2017 11:06 am

Hi Matt,
Edit your /boot/config.txt to include : dtoverlay=i2s-mmap
was allready enabled. So status still the same.
I think I'll write do the xwax-dev mailing list soon.
If i get it working, I can post the anwser here.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests