setup ok?

Moderator: flatmax

czyskows
Posts: 5
Joined: Sat Jul 29, 2017 2:25 am

setup ok?

Post by czyskows » Mon Jul 31, 2017 4:38 pm

Hi. I've gone through the setup - i think properly - but I'm not getting any sound. The output below is what I'm getting from dmesg:

pi@raspberrypi:~/Desktop/Sounds $ dmesg | grep audio
[ 9.111460] audioinjector-octo soc:sound: ASoC: CODEC DAI cs42448 not registered - will retry
[ 9.111485] audioinjector-octo soc:sound: snd_soc_register_card failed (-517)
[ 10.673273] audioinjector-octo soc:sound: cs42448 <-> 20203000.i2s mapping ok

This is the output I get from aplay:

pi@raspberrypi:~/Desktop/Sounds $ aplay --channels=2 CaptainVhdVhd2.wav
Playing WAVE 'CaptainVhdVhd2.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
aplay: set_params:1239: Channels count non available


Can you tell me if it looks like things are working properly, or if there is something I should try again?

Thank you!

czyskows
Posts: 5
Joined: Sat Jul 29, 2017 2:25 am

Re: setup ok?

Post by czyskows » Tue Aug 01, 2017 6:12 am

On this same topic, I'm trying to test the pins from the RPi on my scope to see if I'm getting any clocks or data (which I don't seem to be). I'm assuming that the pins used are just the regular I2S pins...? In other words,
3 = SDA
5 = SCL
12 = BCLK
35 = LRCLK
38 = DATA IN
40 = DATA OUT

Can you confirm that this is correct, so I know which pins I should be checking?

Thanks!

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: setup ok?

Post by flatmax » Tue Aug 01, 2017 9:21 am

Hi there,

OK - I think you need to setup asoundrc again. I have just updated the setup instructions to version 0.3. So lets try to fix what may be your problem.

Firstly, disable lxpanel's volume plugin so it doesn't mess with your alsa setup - cut and paste this into your command line (or reinstall using the deb file on the setup page) :

Code: Select all

sed -i 's/\=volumealsa/\=REMOVEvolumealsa/' ~pi/.config/lxpanel/LXDE-pi/panels/panel
Next uninstall pulseaudio :

Code: Select all

sudo apt remove pulseaudio
Finally assuming your /etc/asound.conf is setup correctly, then remove ~/.asoundrc :

Code: Select all

rm ~/.asoundrc
Now place the following in your .asoundrc :

Code: Select all

pcm.!default {
#       type hw
#       card 0
        type plug
        slave.pcm "anyChannelCount"
}

ctl.!default {
        type hw
        card 0
}
OK - at this point you should be able to play the 2 channel wav file. If you still have problems, test using the anyChannelCount :

Code: Select all

speaker-test -DanyChannelCount
Finally this should work as well :

Code: Select all

speaker-test
This last one automatically uses the anyChannelCount ALSA plugin because that is how the .asoundrc is setup.
Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: setup ok?

Post by flatmax » Tue Aug 01, 2017 9:22 am

czyskows wrote:
Tue Aug 01, 2017 6:12 am
On this same topic, I'm trying to test the pins from the RPi on my scope to see if I'm getting any clocks or data (which I don't seem to be). I'm assuming that the pins used are just the regular I2S pins...? In other words,
3 = SDA
5 = SCL
12 = BCLK
35 = LRCLK
38 = DATA IN
40 = DATA OUT

Can you confirm that this is correct, so I know which pins I should be checking?

Thanks!
Yes, these pins look correct.
Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

czyskows
Posts: 5
Joined: Sat Jul 29, 2017 2:25 am

Re: setup ok?

Post by czyskows » Tue Aug 01, 2017 3:14 pm

Thanks very much for your reply. For some reason, it's still not working. I checked /boot/config.txt and see these:
dtparam=i2c_arm=on
.
.
.

# Enable audio (loads snd_bcm2835)
#dtparam=audio=on
# enable the AudioInjector.net sound card
dtoverlay=audioinjector-addons
# enable the AudioInjector.net sound card
dtoverlay=audioinjector-addons


I don't know if it matters, but the fact that audioinjector-addons shows up twice suggests that I did something wrong.

When I hook up my scope, I'm still not getting any signals from the clocks. I think I'll start over with a fresh image and go through the setup. I'll let you know if I'm still having problems or if everything is working. Thanks again for the help!

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: setup ok?

Post by flatmax » Tue Aug 01, 2017 8:17 pm

OK - if you still don't have any luck, then we should talk privately about this.

Matt
Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

czyskows
Posts: 5
Joined: Sat Jul 29, 2017 2:25 am

Re: setup ok?

Post by czyskows » Thu Aug 03, 2017 12:32 pm

Hi Matt,

For some reason, I'm still having the same issues. I tried installing on a fresh image, but got the same errors:
pi@raspberrypi:~ $ dmesg | grep audio
[ 8.470535] audioinjector-octo soc:sound: ASoC: CPU DAI (null) not registered - will retry
[ 8.470561] audioinjector-octo soc:sound: snd_soc_register_card failed (-517)
[ 10.030491] audioinjector-octo soc:sound: ASoC: CPU DAI (null) not registered - will retry
[ 10.030518] audioinjector-octo soc:sound: snd_soc_register_card failed (-517)
[ 11.590471] audioinjector-octo soc:sound: ASoC: CPU DAI (null) not registered - will retry
[ 11.590496] audioinjector-octo soc:sound: snd_soc_register_card failed (-517)

pi@raspberrypi:~ $ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
anyChannelCount
default

I've tried the install now several times. Any ideas?
I can be reached at colin.zyskowski@gmail.com if you would like to continue this offline.

Thanks,
Colin

flatmax
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Re: setup ok?

Post by flatmax » Tue Aug 08, 2017 8:47 pm

OK - I will contact you off list.

Matt
Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

mrtrvr
Posts: 3
Joined: Wed Jun 28, 2017 12:51 am
Location: St. Louis, MO

Re: setup ok?

Post by mrtrvr » Fri Aug 11, 2017 3:18 am

Greetings,

I appear to be having the same problem as Colin, or at the very least I believe our issues may be related to the same problem. I am able to playback audio as it streaming from the internet, but I am not able to feed a signal into the Audioinjector and monitor it through the output. I have already worked through Tutorial 0, but I am not able to successfully execute all the steps of Tutorial 2 - Audio programming with gtkIOStream.

I also ran the dmesg command and received a similar output:
  • [6.229426] audioinjector-octo soc:sound: ASoC: CPU DAI (null) not registered - will retry
    [6.229447] audioinjector-octo soc:sound: snd_soc_register_card failed (-517)
    [7.792780] audioinjector-octo soc:sound: cs42448 <-> 3f203000.i2s mapping ok
    [7.865506] uart-pl011 3f201000.serial: no DMA platform data
I also noticed that dmesg is printing the following error related to the Broadcom Processor:
  • [6226.711602] bcm2835-i2s 3f203000.i2s: I2S SYNC error!
Is it possible that the problem is associated with the Broadcom processor? The Raspberry Pi hardware documentation is listing the BCM2837 as the processor used in the Raspberry Pi 3.

In case it helps, I've included the printout from: dmesg | grep bcm2835
  • [0.078602] bcm2835-mbox 3f00b880.mailbox: mailbox enabled
    [0.148900] bcm2835-dma 3f007000.dma: DMA legacy API manager at bb80f000, dmachans=0x1
    [0.330715] bcm2835-rng 3f104000.rng: hwrng registered
    [0.788503] bcm2835-wdt 3f100000.watchdog: Broadcom BCM2835 watchdog timer
    [0.788790] bcm2835-cpufreq: min=600000 max=1200000
    [0.789524] sdhost-bcm2835 3f202000.sdhost: could not get clk, deferring probe
    [0.791711] mmc-bcm2835 3f300000.mmc: could not get clk, deferring probe
    [0.889393] mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)
    [0.891619] mmc-bcm2835 3f300000.mmc: mmc_debug:0 mmc_debug2:0
    [0.891626] mmc-bcm2835 3f300000.mmc: DMA channel allocated
    [4.558955] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
    [ 6226.711602] bcm2835-i2s 3f203000.i2s: I2S SYNC error!
Regards,

Trevor

mrtrvr
Posts: 3
Joined: Wed Jun 28, 2017 12:51 am
Location: St. Louis, MO

Re: setup ok?

Post by mrtrvr » Fri Aug 11, 2017 3:33 am

Greetings,

I appear to be having the same problem as Colin, or at the very least I believe our issues may be related to the same problem. I am able to playback audio as it streaming from the internet, but I am not able to feed a signal into the Audioinjector and monitor it through the output. I have already worked through Tutorial 0, but I am not able to successfully execute all the steps of Tutorial 2 - Audio programming with gtkIOStream.

I also ran the dmesg command and received a similar output:
  • [6.229426] audioinjector-octo soc:sound: ASoC: CPU DAI (null) not registered - will retry
    [6.229447] audioinjector-octo soc:sound: snd_soc_register_card failed (-517)
    [7.792780] audioinjector-octo soc:sound: cs42448 <-> 3f203000.i2s mapping ok
    [7.865506] uart-pl011 3f201000.serial: no DMA platform data
I also noticed that dmesg is printing the following error related to the Broadcom Processor:
  • [6226.711602] bcm2835-i2s 3f203000.i2s: I2S SYNC error!
Is it possible that the problem is associated with the Broadcom processor? The Raspberry Pi hardware documentation is listing the BCM2837 as the processor used in the Raspberry Pi 3.

In case it helps, I've included the printout from: dmesg | grep bcm2835
  • [0.078602] bcm2835-mbox 3f00b880.mailbox: mailbox enabled
    [0.148900] bcm2835-dma 3f007000.dma: DMA legacy API manager at bb80f000, dmachans=0x1
    [0.330715] bcm2835-rng 3f104000.rng: hwrng registered
    [0.788503] bcm2835-wdt 3f100000.watchdog: Broadcom BCM2835 watchdog timer
    [0.788790] bcm2835-cpufreq: min=600000 max=1200000
    [0.789524] sdhost-bcm2835 3f202000.sdhost: could not get clk, deferring probe
    [0.791711] mmc-bcm2835 3f300000.mmc: could not get clk, deferring probe
    [0.889393] mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)
    [0.891619] mmc-bcm2835 3f300000.mmc: mmc_debug:0 mmc_debug2:0
    [0.891626] mmc-bcm2835 3f300000.mmc: DMA channel allocated
    [4.558955] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
    [ 6226.711602] bcm2835-i2s 3f203000.i2s: I2S SYNC error!

Regards,

Trevor

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests