Volumio setup for the Octo (without building)

Moderator: flatmax

Post Reply
Posts: 609
Joined: Sat Jul 23, 2016 11:39 pm

Volumio setup for the Octo (without building)

Post by flatmax » Sat Aug 26, 2017 11:51 pm

This post will tell you how to install volumio on a Pi for the Audio Injector Octo 8 channel card.

Firstly download the volumio image and extract it, then write it to an SDCARD, you can get it here.

Now insert that card into your Pi and wait something like 5 minutes. Next enable ssh so that you can setup the audio driver. To enable ssh, go http://volumio.local/DEV/ in your browser and click "ENABLE" under SSH. It doesn't report anything but you have just enabled the SSHd daemon. You can now login to your volumio device.

Open a terminal and tell ssh to connect to the Pi like so :

Code: Select all

ssh volumio@volumio.local
The password is volumio

Setup the /boot/config.txt file by editing it as super user (password is volumio) :

Code: Select all

sudo nano /boot/config.txt
Adding this line to the /boot/config.txt file (I put mine at the end of the file) :

Code: Select all

Also comment out the lines which relate to the onboard Pi PWM audio system :

Code: Select all

The /boot/config.txt file looks something like this now :

Code: Select all

initramfs volumio.initrd
Now reboot :

Code: Select all

sudo reboot
At this point you can log back in and check the card is enabled like so :

Code: Select all

volumio@volumio:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: audioinjectoroc [audioinjector-octo-soundcard], device 0: AudioInject-HIFI cs42448-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
That is it !
It should be working.

Check out our audiophile quality crossovers : https://bit.ly/2kb1nzZ
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
Check out our new forum on github : https://github.com/Audio-Injector

Posts: 1
Joined: Sun Jun 10, 2018 10:18 am

Re: Volumio setup for the Octo (without building)

Post by derEremit » Sun Jun 10, 2018 12:17 pm

It's working for me but just with one channel!

I tried with and withoud /etc/asound.conf like from here

does not make any difference
my goal is to create a 5.1 setup to play 5.1 flacs

volumio@volumio:~$ aplay -L
Discard all samples (playback) or generate zero samples (capture)
Default Audio Device
Direct sample mixing device
Direct sample snooping device
Direct hardware device without any conversions
Hardware device with all software conversions
volumio@volumio:~$ speaker-test

speaker-test 1.0.28

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 32 to 32768
Period size range from 16 to 16384
Using max buffer size 32768
Periods = 4

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest