Octo doesn't work - Need help.

Moderator: flatmax

Post Reply
Posts: 4
Joined: Sun Jun 25, 2017 8:23 pm

Octo doesn't work - Need help.

Post by DK7FC » Fri Jun 08, 2018 3:21 am

Hi all,

Here i'm running an octo-soundcard on the RPI-2B.
I tried starting to record from the octo soundcard but it doesn't work :? After the initialisation i'm getting error messages.
The soundcard appears into the alsamixer, so there must be some basic communication.
arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: audioinjectoroc [audioinjector-octo-soundcard], device 0: AudioInject-HIFI cs42448-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

For example i tried to record with:
sudo AUDIODEV=hw:1,0 rec -c8 -r48000 -b16 -t raw --buffer 32768 test.dat
Input File : 'hw:1,0' (alsa)
Channels : 8
Sample Rate : 48000
Precision : 16-bit
Sample Encoding: 16-bit Signed Integer PCM

In:0.00% 00:00:00.00 [00:00:00.00] Out:0 [ | ] Clip:0 rec WARN alsa: Input/output error
rec FAIL sox: `hw:1,0' Device or resource busy: Operation not permitted
In:0.00% 00:00:00.00 [00:00:00.00] Out:0 [ | ] Clip:0

Then i started to search for hardware issues and measured some voltages. Searched for bridges between some pins and so on.
I measured the 1.2 V ref voltage as well as 3.3 V and 5.0V and also i can measure the 49.15 MHz oscillator signal. On all of the GPIO Pins i can measure constant logic levels 0 / 3.3 V but no clock signal for example.

This may be a suspicious sign: I can measure the current consumption of the RPI. When connecting the power supply and booting it consumes 220 mA (here using a 12V>5V DC/DC converter with 80% efficiency. Current measured on the '12V' level). The main IC (CS42448) is getting slightly warm. But when trying to record from the octo the current consumption suddenly drops to 150 mA and the IC is getting cold! After a reboot the current consumption is still 150 mA. But when shutting down the RPI and the power supply, the powering on and booting, then the current consumption becomes 220 mA again.
Does someone have an idea? Eventually there is a overcurrent protection triggering? So what causes the intensive current consumption?

And not to forget, dmesg tells first:
dmesg | grep octo
[ 7.404037] audioinjector-octo soc:sound: cs42448 <-> 3f203000.i2s mapping ok

but later it tells:
bcm2835-i2s 3f203000.i2s: I2S SYNC error!
bcm2835-dma 3f007000.dma: DMA transfer could not be terminated

Any ideas? Your help is apprechiated.

Regards, Stefan

Posts: 4
Joined: Sun Jun 25, 2017 8:23 pm

Re: Octo doesn't work - Need help.

Post by DK7FC » Fri Jun 08, 2018 7:14 pm

Oh, i just found that i didn't follow the installation process as recommended here in the forum.
Well: Pulseaudio wasn't installed anyway.
I did then download and extract the audioinjector.octo.setup_0.3_all.deb file and tried to install it. But this didn't work either. I'm getting this message:
sudo dpkg -i audioinjector.octo.setup_0.3_all.deb
(Reading database ... 35595 files and directories currently installed.)
Preparing to unpack audioinjector.octo.setup_0.3_all.deb ...
Unpacking audioinjector.octo.setup (0.3) over (0.3) ...
Setting up audioinjector.octo.setup (0.3) ...
updating the kernel
sudo: rpi-update: command not found
dpkg: error processing package audioinjector.octo.setup (--install):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:

Maybe worth to mention that it is my second octo-soundcard. The first one runs without problems. Both of them are version V1.16. The system on the Raspi is a clone of the Raspi using the first octo-soundcard. Anyway i run an update and upgrade. 'rpi-update' is unknown here. I run a dist-upgrade and it tells me there is nothing to upgrade but one is not fully installed.

I made sure that

is contained into /boot/config.txt

Does someone have an idea what i'm doing wrong or missed to do?

Regards, Stefan

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests