The channels change all the time :(

Moderator: flatmax

Post Reply
nico_lh
Posts: 1
Joined: Fri Nov 09, 2018 5:50 am

The channels change all the time :(

Post by nico_lh » Fri Nov 09, 2018 5:57 am

Hi, I am very new in raspberry pi and using the terminal and those things. I got to install my Octo Sound Card and it works (I only tested output so far). But every time I restart the raspberry it changes the channel configuration. For example, the output that I used for channel 1, changes to 3 and then to another one. This is very confusing and I don't know how to fix it. I am using Reaper right now to assign different channels for outputting 8 different audio tracks. I am trying to use the Octo + RasPi for an 8 channel sound installation that will be left at a gallery and will be turned on and off every day, so this is a big problem since the sound will always come from different speakers. How can I fix this? Should I try to use any other DAW, any suggestions? Please help <3

flatmax
Posts: 604
Joined: Sat Jul 23, 2016 11:39 pm

Re: The channels change all the time :(

Post by flatmax » Mon Nov 12, 2018 9:18 pm

Are you using asynchronous playback/capture ?

If you open either play or capture and at a later time open the other, i.e. Half duplex then full duplex operation, you will notice channel swapping.

To stop this occurring you need to open the device full duplex - i.e. playback and capture together - which is standard in most situations.

See here for the asynchronous operation known bug :
viewtopic.php?f=9&t=1221
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest