Testing Octo

Moderator: flatmax

Ivan
Posts: 11
Joined: Thu Jan 11, 2018 10:33 pm

Re: Testing Octo

Post by Ivan » Mon Feb 26, 2018 12:23 am

OK, I really want this Octo board to work. I saw the post using jaaa so i intalled and ran it, hoping to get some idea why this setup isn't working. Well, what I got was - no input, no noise, nothing.... and that with the input dynamic range graph set to 140 dB. So it seems I have some sort of silent failure... your board is not that good :-) as to have no noise at -140 dB.

I used the install procedure... everything seemed to go well, but alas, nothing works for the audio. In fact, all audio is now gone, nothing on the 3.5 mm jack, nothing on the HDMI, nothing on the octo.

Can you give me kind of help here... how does one go by testing if we have a board failure (ALSA and jaaa see the board, so that's probably not the case) and if it's not a bad board problem, what is the path the audio signal follows... (config file contents,etc) and how does one trace the and identify the problem cause... because I can't get either input or output to work.

Any help would be appreciated.

Dloranger
Posts: 8
Joined: Tue Jan 02, 2018 2:10 pm

Re: Testing Octo

Post by Dloranger » Fri Mar 09, 2018 8:34 am

Just as a couple thoughts if you haven't already figured out a solution, as I have been having some issues as well/

I manually performed the setup as outlined in the forum. All that went fine.

run alsamixer, and use F5 to see all the signals, I usually set mine to 60%ish so I have room both ways and wont distort.

after setting alsamixer, reenter to make sure the settings stick, and if they did do a reboot, or they will get lost if you remove power.

Once the system is back up, run "speaker-test -c 8 -t sine -f 500", this will cycle channel by channel playing out a tone of 500 Hz for about 1 second per channel.

I have had one instance where something got corrupted, and all I got was very low level noise, or signal that was AM modulated with some unknown 5-15KHz carrier. This persisted even after replacing the codec chip on the board! Reformatting the SD card and reinstalling debian and the octo configs fixed this up.

Good luck

Ivan
Posts: 11
Joined: Thu Jan 11, 2018 10:33 pm

Re: Testing Octo

Post by Ivan » Sat Mar 10, 2018 1:41 pm

Installed a new SD car with new OS, followed the instructions... to no avail...grrrrr... so being an ee, I went and looked at the schematics and found the answer... now I get stereo audio output :D

Nowhere in the product description does it state how many inputs there are and how many outputs :o . I thought there were 8 inputs and 6 outputs. Fact is, it's the reverse! There are 8 outputs and 6 inputs. The connectors are not keyed or different, so there is nothing to inform your customer about this.

May I suggest a product description improvement by stating somewhere the are 6 inputs and 8 outputs. Seems strange to me that such a device has more outputs than inputs as in audio, you generally mix inputs into less output busses than you have input busses. Anyhow, I hope plugging the RCA board backwards like that doesn't damage anything... I haven't gone far enough to ascertain that and looking at the schematics, I am left to wonder :( .

howcanea
Posts: 1
Joined: Wed Mar 14, 2018 10:49 pm
Contact:

Re: Testing Octo

Post by howcanea » Thu Mar 15, 2018 6:43 pm

How to marking those octo towards that testing points

flatmax
Posts: 603
Joined: Sat Jul 23, 2016 11:39 pm

Re: Testing Octo

Post by flatmax » Sun Mar 25, 2018 7:22 pm

Ivan wrote:
Sat Mar 10, 2018 1:41 pm
Installed a new SD car with new OS, followed the instructions... to no avail...grrrrr... so being an ee, I went and looked at the schematics and found the answer... now I get stereo audio output :D

Nowhere in the product description does it state how many inputs there are and how many outputs :o . I thought there were 8 inputs and 6 outputs. Fact is, it's the reverse! There are 8 outputs and 6 inputs. The connectors are not keyed or different, so there is nothing to inform your customer about this.

May I suggest a product description improvement by stating somewhere the are 6 inputs and 8 outputs. Seems strange to me that such a device has more outputs than inputs as in audio, you generally mix inputs into less output busses than you have input busses. Anyhow, I hope plugging the RCA board backwards like that doesn't damage anything... I haven't gone far enough to ascertain that and looking at the schematics, I am left to wonder :( .
Oh boy ! I just realised that it was possible that your output and input connectors were reversed ! Glad you found it out :)
I should really mark things a little more carefully.

Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

flatmax
Posts: 603
Joined: Sat Jul 23, 2016 11:39 pm

Re: Testing Octo

Post by flatmax » Sun Mar 25, 2018 7:23 pm

howcanea wrote:
Thu Mar 15, 2018 6:43 pm
How to marking those octo towards that testing points
Hi, Please ask your question again, I didn't understand.

Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

Ivan
Posts: 11
Joined: Thu Jan 11, 2018 10:33 pm

Re: Testing Octo

Post by Ivan » Fri Mar 30, 2018 6:34 pm

OK, so I flashed a new image on a SD card, followed your script and voila... I get sound on 2 of the outputs. I installed Ardour and it sees the 6 inputs as working. However it detects 8 inputs... do you have an idea of what those 2 extra inputs are? Is there a way to test all outputs?

flatmax
Posts: 603
Joined: Sat Jul 23, 2016 11:39 pm

Re: Testing Octo

Post by flatmax » Sat Mar 31, 2018 1:27 pm

Those 2 extra inputs are phantom inputs ! Just part of the DMA mechanism.

You can loop back 6 outputs to test and then again with the last 2 outputs. Or you can use a mixer like this :
https://www.amazon.co.uk/dp/B00UIP0IPO
https://www.amazon.com/dp/B00UIP0IPO

To mix 2 lines down to one.

Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

scotmaria
Posts: 1
Joined: Mon Aug 27, 2018 5:47 pm
Contact:

Re: Testing Octo

Post by scotmaria » Tue Aug 28, 2018 5:05 pm

howcanea wrote:
Thu Mar 15, 2018 6:43 pm
How to marking those octo towards that testing points

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests