Octo on 2018-11-13 raspbian stretch lite not working

Moderator: flatmax

Post Reply
jochen.richert
Posts: 1
Joined: Thu Jan 10, 2019 6:41 pm
Contact:

Octo on 2018-11-13 raspbian stretch lite not working

Post by jochen.richert » Thu Jan 10, 2019 7:13 pm

Hello

I just received my octo cards and would like to use the inputs on my octocard to capture sounds, but do not get it running.

Here's my config:
Raspberry Pi Model B Plus Rev 1.2
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

I can't use the sudo dpkg -i Downloads/audioinjector.octo.setup_0.3_all.deb command so I gone the manual way via Firmware Upgrade which was running fine.

Also the changes in the /boot/config.txt are done.
# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README
# Enable audio (loads snd_bcm2835)
#dtparam=audio=on
# enable the AudioInjector.net sound card
dtoverlay=audioinjector-addons


pi@vlf-01-pi:~ $ dmesg | grep audio
[ 15.243097] audioinjector-octo soc:sound: ASoC: CPU DAI (null) not registered - will retry
[ 15.243133] audioinjector-octo soc:sound: snd_soc_register_card failed (-517)
[ 16.803100] audioinjector-octo soc:sound: ASoC: CODEC DAI cs42448 not registered - will retry
[ 16.803134] audioinjector-octo soc:sound: snd_soc_register_card failed (-517)
[ 21.996351] audioinjector-octo soc:sound: cs42448 <-> 20203000.i2s mapping ok

After that I run all these commands
sudo modprobe -r snd_soc_audioinjector_octo_soundcard
sudo modprobe -r snd_soc_cs42xx8_i2c
sudo modprobe -r snd_soc_cs42xx8
sudo modprobe snd_soc_cs42xx8
sudo modprobe snd_soc_cs42xx8_i2c
sudo modprobe snd_soc_audioinjector_octo_soundcard

No error message, just this line added to DMESG

[ 107.347648] audioinjector-octo soc:sound: cs42448 <-> 20203000.i2s mapping ok
pi@vlf-01-pi:~ $

Any idea what I can further do?

Many thanks
Jochen

flatmax
Posts: 608
Joined: Sat Jul 23, 2016 11:39 pm

Re: Octo on 2018-11-13 raspbian stretch lite not working

Post by flatmax » Fri Jan 11, 2019 5:34 am

Hi there,

I am currently remote - with no Octo. I will check this problem later this month and get back to you.
In the mean time, you may want to downgrade your kernel (using rpi-update) to a slightly older version since before this problem showed up.
rpi-update VERSION
Where VERSION is the git commit number from here :
https://github.com/Hexxeh/rpi-firmware/commits/master

For example this would take it back around one month ago :
rpi-update eefe4b161f5e9730183c8dc1605e14c85b15cf51

thanks
Matt
Checkout the next kickstarter campaign - the Ultra 2 : https://kck.st/2xwM3DL
Please review the Zero sound card on Amazon USA : https://www.amazon.com/dp/B075V1VNDD
---
Check out our new forum on github : https://github.com/Audio-Injector

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests